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Legal Notice 
  

This guide explains how to configure and use Wrapsody eCo provided by Fasoo, Inc. The contents of 
this document and the programs specified in it are protected by applicable copyright laws. This 
document and the programs explained in it may only be used under a license agreement with Fasoo, 
Inc. No part of this document may be transmitted, copied, distributed, or reproduced by any means 
(electronic, mechanical, recording, or otherwise) without written permission of Fasoo, Inc. 
Information in this document is subject to change without notice as improvements are made to the 
product. 
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Revisions 
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Jan 25, 2022 
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Revised for v2.4. 
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Oct. 24, 2023 
Revised for v2.5. 
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Get stared with Wrapsody eCo 
Organizations engaged in extensive external collaboration need a clear overview of their project flow, ensuring shared 
files with team members are up-to-date and securely managed. Wrapsody eCo fulfills these needs and surpasses 
traditional, inefficient, and insecure file-sharing models by consolidating various channels and systems into a single 
communication channel, streamlining the process. It provides a fast and lightweight web interface that doesn't usually 
require additional program installation. 

 

Get the most out of Wrapsody eCo! 
Q1: Did you sign up for Wrapsody eCo for the first time in an email invitation from a project team member? 
A: Visit the workgroup where your project team members are, see the project history, and view and use the project 
files. 
 
Q2: What are the benefits of using Wrapsody eCo? 
A: Numerous decisions are made and changed once a project begins. In the past, whenever there is a change made to a 
file, one would generally update it and send the updated version to relevant staff members by email. However, this 
process is not only repetitive and cumbersome, but also inefficient in many ways, as one could send the wrong version 
of the file or omit a recipient.  
With Wrapsody eCo, any changes made to a shared file from individual PCs are synchronized with the server so that when 
an authorized user opens the file, it is automatically updated without needing to be re-sent after every revision. Users 
can check the latest versions of files using web browsers without additional software installation, repetitive downloads, 
and sign ups, which saves time for checking the revisions. File usage permissions can be granted by file or by user, 
preventing information leakage and other security issues. 
 
Q3: How can I share files? 
A: There are various ways to share files on Wrapsody eCo. You can upload files to workgroups created for each project, 
send files to individual users even if they are not members of the workgroup, and share file links with users who have 
permissions for the files. 
 
Q4: What is the purpose of creating a workgroup, and how can I create one? 
A: Not only can you easily share project files with the project team members, but you can also communicate with them 
through one channel of Wrapsody eCo without switching to other channels such as phone calls or messenger programs. 
In addition, all the comments exchanged among the members will be kept even after the project is completed so that 
they can be managed as project deliverables. To create a workgroup, see Create workgroups. 
 
Q5: How can I view my most recently updated files? 
A: When a user edits and checks in a file, it is saved as a new version on the server. If the file is stored on the user’s local 
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PC, they can opt to open the latest version when running the file. On the Workgroup File tab of the Wrapsody eCo website, 
users can check the Last update date and version information for each file. 
 
Q6: How can I access previous versions of files?. 
Each time a Wrapsody eCo file is revised, the modifications are saved on the server, so when you need to check the 
contents of the previous version, you can download the required version. To download the previous version, select the 
workgroup and go to the File tab. Click on the desired file to view its Details in the right pane. Then scroll down to File 

history. Hover your mouse over the specific version you want to download. Then click on the Download icon  of the 
desired version to download.  
 
Q7: How can I prevent other users from printing, screen capturing, and copying or pasting text? 
A: Wrapsody eCo provides precise control over viewer actions when using files. To control workgroup permissions at a 

granular level, click on the Workgroup Details icon  to the right of the workgroup name to open the Workgroup 
Details dialog box. Here, in the Workgroup Permissions tab, enable file downloads, check the Protect (File encryption) 
option, and select Don’t allow for permissions you want to restrict for users (e.g., Print, Screen capture, Copy file text). 
Additionally, you can assign different permissions to individual members for specific files. 
 
Q8: How can I grant different permissions for certain files to project team members? 
A: There are situations where specific permissions must be assigned to individual members within a workgroup based 
on the file's security level or the member's responsibilities. Wrapsody eCo's customization empowers the workgroup 
head to tailor view and download permissions for each file to individual members. 
To set permissions for a specific file to different users, hover your mouse over the desired file in the File tab and click the 

More icon  > File Permissions. When you see the list of users for the file, change the permission option of the desired 
user to Personal permissions. 
Once the list of users for that file appears, you can modify permissions by clicking on the current permission of the user 
whose access you wish to modify. You can either select Personal permissions to modify or choose No permission to 
revoke access entirely. 
You can also set permissions for each user on a per-file basis in My Inbox as well. 
 
Q9: I no longer need to keep a file shared. Can I revoke the granted permissions for that shared file? 
A: Absolutely, you can safeguard your organization's intellectual assets even after a project concludes by revoking 
permissions for shared files. To revoke permissions for a specific file from different users, hover your mouse over the 

desired file in the File tab and click More button  > File Permissions. When you see the list of users for the file, change 
the permission option of the desired user to No permission. 

 

Q10: What are the privileges of file owners, and can their roles be altered or transferred? 
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File owners in Wrapsody eCo are users who initially uploaded or sent the files. They have the authority to grant 
permissions to new file users and modify the permissions previously assigned. For files shared to a workgroup, the head 
of the workgroup can change the file owner to a different member. 

Q11: How can I communicate with project members? 
In Wrapsody eCo, communication options include leaving comments on files, chatting, and sending view alerts. The file 
commenting feature notifies users who share the same file, regardless of their workgroup membership, about changes 
made to the file. Leaving version-specific comments facilitates easy tracking of changes across versions. Additionally, each 
workgroup has its own chat rooms, allowing members to exchange messages conveniently. However, please be aware 
that chat functionality may be limited depending on the subscription plan. Additionally, utilizing the view request feature 
after file modifications makes it easy to prompt other users to review the file. 

Q12: What are the main differences between Wrapsody eCo and Wrapsody eCo Cloud? 

Features Wrapsody eCo Wrapsody eCo Cloud 

Maximum attachment size Changeable 200 MB 

Linking with an MS 365 account Consult with the representative. Link instantly. 

 

Key features 

Easy file sharing and version control 
This innovative collaboration platform empowers project teams to effortlessly form workgroups and communicate, 
regardless of their affiliations. When files are shared via Wrapsody eCo, its auto-synchronization feature automatically 
updates all shared files, including those saved on individual PCs. This eliminates the need to send updated files via email 
after each revision, streamlining the collaborative process. 
 
Precise permission management tailored to files and users 
Wrapsody eCo offers detailed file management, allowing precise assignment of varied permissions to individual users. It 
provides robust protection for shared file content, giving control over actions like printing, copying, and pasting. 
Additionally, permissions can be revoked after project completion, ensuring enhanced security. 
 
Seamless project management 
Internal and external users are seamlessly organized into workgroups, enabling smooth communication. Workgroup 
activities, such as file creation, revision, or deletion, as well as exchanged messages, are meticulously recorded and easily 
accessible. All project communication takes place within a unified platform, providing members with a comprehensive 
view of the project workflow.  
 
Effective management of project deliverables as valuable assets 
Wrapsody eCo preserves all project-related records, including comments and deliverables. This capability enables 
organizations to effectively manage their intangible assets even after project completion, ensuring valuable information 
is not lost. 
 
Preventing security incidents, ensuring data integrity 
All files shared via Wrapsody eCo are encrypted and stored and distributed securely to prevent security incidents. By 
encrypting all shared files and integrating multiple channels into one, Wrapsody eCo effectively safeguards against data 
breaches and security risks, ensuring the integrity of shared information. 
 

Terminology 

Protect (File encryption): The process of converting a plain file into a Wrapsody eCo file. When a user uploads or sends 
a file via Wrapsody eCo, the file is uploaded to the Wrapsody eCo server and converted into a Wrapsody eCo file. Files 
with unsupported extensions for wrapping will be uploaded in their original format. (Supported extensions: doc, docx, 
xls, xlsx, ppt, pptx, txt, hwp, and pdf) 
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Wrapping: The process of encrypting a plain file into a Wrapsody eCo file. 

Wrapsody eCo file: A file uploaded to the Wrapsody eCo server and converted into a Wrapsody eCo file. All derivative 
versions of the Wrapsody eCo files and the version history are stored on the Wrapsody eCo server. When a user edits 
and checks in a Wrapsody eCo file, the file on the server is updated to the latest version. This ensures that other file 
sharers can always Go to most recent version. 

Upload File: To share files with workgroup members by uploading files to your workgroup.  

Share: To share a file, either by uploading it to the server or sending it to collaborators. 

File owner: The user who initially uploaded or sent a file. A file owner can grant or revoke permissions for files to or from 
users. The owner of files shared within a workgroup can be changed to a different member by the head of the workgroup. 

Workgroup: A group of users collaborating on the same project. You can create a workgroup and invite other project 
members. A workgroup consists of the head and members. 

Head of workgroup: The user who initially created a workgroup. The head of a workgroup can be changed by the 
Wrapsody eCo administrator. The head can set default workgroup permissions for the files shared within the group, 
which are uniformly applied to all members. 

Workgroup member: Users involved in a shared project. Employees within an organization can become members by 
addition, while external users must sign up via an email invitation.  

Workgroup permission: The default permissions for a workgroup. The default permissions for files uploaded to a 
workgroup are granted to all members unless modified by the head of the workgroup. 

Internal user: All Wrapsody eCo users within the organization. 

External user: Wrapsody eCo users outside the organization who collaborate with the organization using Wrapsody eCo. 

Recipient: A user who receives files through the file sending feature in My Inbox. File permissions for the file can be 
defined for individual users when sending the file. 

View: Only users with View permissions can open Wrapsody eCo files. Users with View permissions can open Wrapsody 
eCo files in read-only mode. 

Edit (Revise): Edit in Wrapsody eCo is the process of modifying Wrapsody eCo files and registering them as new versions 
on the server. 

Unwrap: The process of reverting a Wrapsody eCo file back to its original plain state before downloading it. 

Wrapsody eCo client: A program installed on the user's PC that allows modification of Wrapsody eCo files using their 
native applications (e.g., MS Word program for MS Word files) and sharing the latest version with other users. 

Web editor: Content editing tool used to revise files online. 

File ID: Every Wrapsody eCo file has a unique syncing ID. Files with the same file ID are recognized as a single file on the 
Wrapsody eCo server, and may exist in multiple paths on the user's local PC. Since they share the same synchronization 
ID, the file stays up to date regardless of its storage location. 

Guide set 
Wrapsody eCo Admin Guide: A guide for administrators within an organization that has adopted Wrapsody eCo. It 
provides instructions on how to manage Wrapsody eCo, including organization and administration settings, the deletion 
of workgroups, etc. 

Wrapsody eCo User Guide: A guide for Wrapsody eCo users. It explains how to use Wrapsody eCo for effective 
collaboration, including creating workgroups, sharing files, and more. 
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Wrapsody eCo Installation Guide: A guide for installing a Wrapsody eCo server. 

Solution architecture 
Wrapsody eCo comprises a server and a desktop application client. By default, all features are accessible on the web 
without needing to install the client. However, if you want to revise files other than Microsoft Office files or revise them 
using their native applications (e.g., Microsoft Word, Excel, PowerPoint), the client installation is necessary. 

System requirements 
Check the minimum or recommended system requirements for Wrapsody eCo. 

Client 
HW 

 CPU: i5 

 RAM: 4 GB 

 HDD: 100 GB 

OS 

 Microsoft Windows 10 (RS1) 

 Mac 11.0 

Server 
HW 

 CPU: Xeon 2.5 Ghz Quad Core(64 bit) 

 RAM: 32 GB (64 GB or more recommended) 

 HDD: 300 GB (Separate storage space required) 

OS 

 Windows Server 2012 (64 bit), CentOS 6.10, Ubuntu 16.04 LTS, Redhat RHEL 7.5 

Supported web browsers 
 Internet Explorer 
 Chrome 
 FireFox 
 Safari 
 

Sign up 
Recipients of an email invitation can join Wrapsody eCo. If you are already a member of an organization utilizing 
Wrapsody eCo, you may skip the sign-up process. 

1. Open the Wrapsody eCo invitation email and click on the Sign up link provided. 
2. You'll be redirected to the sign-up webpage. 
3. Complete all mandatory fields. 
4. Click Sign up to complete the process. 

Access Wrapsody eCo website 

Wrapsody eCo website address 
The address to access Wrapsody eCo varies depending on whether the user is an internal user of the organization or an 
external user belonging to a collaborative partner. For internal users, please contact your organization's Wrapsody eCo 
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administrator. For external users who have received invitation emails from collaborative partners, please reach out to 
the inviter. 

Note: The default address for the Wrapsody eCo website is https://[organization(domain) name].wrapsodyeco.com. 
 Example: https://fasoo.wrapsodyeco.com 

Access Wrapsody eCo website via web browser 
1. Open a supported web browser (Chrome, Edge, Firefox, Safari). 
2. Enter the Wrapsody eCo website address and press Enter. 
3. You will be directed to the Wrapsody eCo website. If login is required, proceed with logging in. 

Access Wrapsody eCo website via the client 
If the website is registered on the client, accessing the Wrapsody eCo website is easy from the client. Check the website 
currently accessed on the top left corner of the client. To access a different website, click on the site name and select the 
desired Wrapsody eCo website. 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. If login is required, proceed with logging in. 

3. Click on the Wrapsody eCo website icon  on the top right corner. 
4. You will be directed to the Wrapsody eCo website. 

Log in 

Initial login (Registering a Wrapsody eCo website) 
When you first log in to the Wrapsody eCo Client, you are required to register a website address specific to your 
company. Follow these procedures to register a website. 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. In the login dialog box, enter your Wrapsody eCo address in the Wrapsody eCo address input box. 
3. Enter your User ID and Password registered with Wrapsody eCo. If you select the Remember my user ID checkbox, 

the entered user ID will be saved and displayed automatically the next time you log in (optional). 
4. Click the Log in button. 

Log in 
You can log in through both the web and client interfaces. Employees of companies using Wrapsody eCo should utilize 
their internal account details. If you've been invited by a collaborative partner, your registered email serves as your ID 
during login. Keep in mind that login IDs may differ based on each organization's Wrapsody eCo settings, so it's 
recommended to contact your internal Wrapsody eCo administrator for clarification. 

Route 1. Web 

1. Go to the Wrapsody eCo website. 
2. On the login page, enter your User ID and Password. 
3. If you select the Remember my user ID checkbox, the entered user ID will be saved and displayed automatically the 

next time you log in (optional). 
4. Click the Log in button. Upon successful login, you will be redirected to the Home page of Wrapsody eCo. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. In the login dialog box, enter your User ID and Password registered with Wrapsody eCo. If you select the Remember 

my user ID checkbox, the entered user ID will be saved and displayed automatically the next time you log in (optional). 
3. Click the Log in button. 

https://fasoo.wrapsodyeco.com/
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Log out 

Route 1. Web 

1. Go to the Wrapsody eCo website. 
2. Click on the user profile icon in the top-right corner of the screen. 
3. Click Log out. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the user profile icon in the top-right corner of the Wrapsody eCo client. 
3. Click Log out. 

Register Wrapsody eCo website 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the site name in the top-left corner of the Wrapsody eCo client. 
3. Click on Register Site. 
4. Enter the Wrapsody eCo address into the input field provided for the Wrapsody eCo website in the login dialog 

box. 
5. Enter your User ID and Password registered with Wrapsody eCo. If you select the Remember my user ID checkbox, 

the entered user ID will be saved and displayed automatically the next time you log in (optional). 
6. Click the Log in button. 

Install Wrapsody eCo client 
Wrapsody eCo is a service that typically doesn't require separate program installation. However, to view and revise 
Wrapsody eCo files downloaded on the user's PC using their native applications (e.g., MS Word for .docx files), installation 
is necessary. Check system requirements before installing the client. 

Supported applications and file formats 
 Microsoft Office 365 (2016 or later) 

- Word 2016(x86/x64), 2019(x86/x64) - doc, docx, docm 

- Excel 2016(x86/x64), 2019(x86/x64) - xls, xlsx, xlsm 

- PowerPoint 2016(x86/x64), 2019(x86/x64) - ppt, pptx 

 Microsoft Notepad for Windows 7(x86/x64), Windows 8/8.1(x86/x64), Windows 10(x86/x64) - txt 

 Acrobat Reader DC - pdf 

 Hancom Hangul 2014, neo, 2018, 2020, 2022 – hwp, hwpx 

How to install 
1. Go to the login page of the Wrapsody eCo website. 

(Example: https://fasoo.wrapsodyeco.com/login) 
2. Click on Download and learn more located at the top right corner. 
3. Click on Download in the Windows section. 

https://fasoo.wrapsodyeco.com/login
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4. Depending on your PC's specifications, choose between Download (32-bit) or Download (64-bit). 
5. Select the destination path for the installation file and click Save. 

Note: Before starting the installation process, ensure there is network connectivity with the server and verify the 
Windows permission status (administrator login is necessary for installation). 

How to uninstall 
You can uninstall the client by running the setup file, or you can restore the Wrapsody eCo client from the Control Panel. 

1. Go to the Control Panel > Programs > Programs and Features. 

2. Right-click Wrapsody eCo Client (or Fasoo Wrapsody eCo), then click Uninstall 

3. Follow the instructions to complete the removal process. 
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Wrapsody eCo interface 

Wrapsody eCo website 
Here are the main areas of the Wrapsody eCo website. 

 
 Navigation menu: The list of workgroups you belong to and files shared can be accessed through the following tabs: 

- Home: The list of workgroups you belong to. You can share files or book video meetings. 
- Bookmarks: A list of your bookmarked files and video meetings. 
- My Inbox: A list of files sent to or received from a user through the file sending feature. 
- Workgroup: A list of all workgroups to which you belong, including your starred workgroups. 
- Trash: A list of files deleted from your workgroup. 

 Search box: You can search for files or video meetings in the search bar. 
 Download and learn more: Clicking the icon will redirect you to the download page. 
 Notifications: View notifications from your workgroups, such as file shares, comments, and other updates. 
 Profile: Click your profile icon for account management, notifications, and logout. 

Wrapsody eCo client 

Click on the Wrapsody eCo icon  in the system tray, and the Wrapsody eCo client will open as shown below. 
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 Currently accessed site: The site name is displayed. Click the down arrow  to show the list of registered sites and 

access other sites by clicking on them. If a new notification icon  appears to the right of the site name, it indicates 
new notifications for the site. 

 Your workgroups: All workgroups to which the logged-in user belongs are displayed, and the user can select the 
desired workgroup by clicking on the workgroup icon. 

 List: Uploaded files, scheduled video conferences, and history for the selected workgroup are displayed in the 
respective File, Meeting, and History tabs. 

 Star: Star or unstar your workgroups. 
 Search: Enter keywords to search for files or video conferences. 
 Bookmarks: A list of files and video conferences bookmarked by the user. 
 Notifications: Real-time notifications such as file updates and comment notifications are displayed. If a red dot 

appears in the top right corner of the icon, it indicates new notifications for the site. 
 Wrapsody eCo web: Go to the Wrapsody eCo website. 
 Profile: Click the icon to log out. 
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Key features of Wrapsody eCo 

Use & manage workgroups 
You can create and oversee workgroups tailored for each project. 

Search for workgroups 
When you navigate to the Workgroup tab, you will find a list of all your workgroups. By configuring the Workgroup, 
Member, and Update filters at the top, you can refine your search to display only the workgroups that meet your specified 
criteria. 
1. Go to the Wrapsody eCo website. 
2. Go to the Workgroup tab in the navigation menu. 
3. Utilize the filters at the top (multiple selections allowed). 

 Workgroup: The Search workgroup window will appear. Type your search terms and click Apply. 
 Member: The Search member window will appear. Type a user name or ID, and a list of users matching your 

search will be displayed. Select your desired user and click Apply. 
 Update: Select a time frame during which updates have occurred. Alternatively, click Custom to specify your 

desired period and click OK. 
4. The search results that meet all your criteria will appear. 

Create workgroups 
1. Go to the Wrapsody eCo website. 

2. Click the Plus icon  of the Workgroup tab from the navigation menu. Alternatively, go to the Workgroup tab and 
click Create Workgroup in the top-right corner of the Workgroup page. 

3. The Create Workgroup dialog box will appear. 
4. Enter a Workgroup name. 
5. In the Workgroup members input field, enter the user’s name (or ID) and, for unregistered users, enter their email 

address. Alternatively, click the Select User button, then click the + button next to the desired user in the org chart, 
review the selection, and click Apply. 

 Select registered users on Wrapsody eCo 
When entering a user ID in the input field, a list of registered users will appear for selection. 

 Select unregistered users on Wrapsody eCo 
Enter the user’s email address and press the Enter key. 

Note: To remove a user from Selected, click the Delete icon  next to their name. 
6. Enter the message for the workgroup creation notification in the Notification email message input field (optional). 
7. Click Workgroup Permissions to set the default file permissions for members, then OK (optional). 
8. Click Create. 
9. Your workgroup is now created. 

Upload files to an existing workgroup 
You can share Wrapsody eCo files or plain files in an existing workgroup. When you upload plain files to Wrapsody eCo, 
they are encrypted (wrapped) and managed as Wrapsody eCo files. 

Note: In Wrapsody eCo Cloud, the maximum upload capacity per file is 200 MB. 

Route 1. Web (Home page) 

1. Go to the Wrapsody eCo website. 
2. Click the Share File to Workgroup button at the top right of the home page. 
3. The Select File to Share window will appear. 
4. Drag the file from the local path on your PC into the window, or click the Upload button, find the desired file in the 

Open dialog, and click Open. 
5. Review the list of Files to share and click Next. 
6. The Select Workgroup window will appear. 
7. Select Share to Existing Workgroup. 
8. Select the workgroup to share the file to and enter a message to be sent via notification email (optional). 
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9. Click Share. 
10. The files will be uploaded to the workgroup. 

Route 2. Web (Workgroup > File tab) 

1. Go to the Wrapsody eCo website. 
2. Access the Wrapsody eCo website. 
3. Click on your desired workgroup from the navigation menu to access its page. 
4. Click the File tab. 
5. Navigate to the path where you want to upload the file. 
6. Drag and drop the file from your PC to the workgroup’s File page. 

Note: Alternatively, click the Upload File button at the top. Drag and drop the file in the Upload File window or click 
"or select a file from your computer," find the file in the Open dialog, and click Open. 

7. Review the list of Files to upload and click OK. 
Note: To add more files, click the Add More File button at the top, select the desired files, and click Open. 

8. The files will be uploaded to the workgroup. 

Route 3. User PC 

You can share files to existing workgroups. 

Note: Files with unsupported extensions for wrapping will be shared in their original format. Refer to supported 
applications and file formats. 

1. Right-click the file you want to share to a workgroup on your PC. 
2. Click Wrapsody eCo > Share files to Workgroup. 
3. Click the Wrapsody eCo site where you want to upload the file. If the login window appears, log in. 
4. Click Next. 
5. In the Share to Workgroup window, review the files to be shared and click Next. 

Note: To delete a file, click the Delete icon  next to it. 
6. The Select Workgroup window will appear. 
7. Select Share to Existing Workgroup. 
8. Choose the workgroup to share the file with. Enter a message to send via email notification (optionally). 
9. Click Share. 
10. Once the upload to the selected workgroup is complete, a Shared to Workgroup window will appear, and the local 

file will be encrypted. 

Upload files to a new workgroup 
You can create a new workgroup and share Wrapsody eCo files or plain files simultaneously. When you upload plain files 
to Wrapsody eCo, they are encrypted (wrapped) and managed as Wrapsody eCo files. 

Note: In Wrapsody eCo Cloud, the maximum upload capacity per file is 200 MB. 

Route 1. Web (Home page) 

1. Go to the Wrapsody eCo website. 
2. Click the Share File to Workgroup button at the top right of the home page. 
3. The Select File to Share window will appear. 
4. Drag the file from the local path on your PC into the window, or click the Upload button, find the desired file in the 

Open dialog, and click Open. 
5. Review the list of Files to share and click Next. 
6. The Select Workgroup window will appear. 
7. Select Share to New Workgroup. 
8. Enter a Workgroup name. 
9. In the Workgroup members input field, enter the user’s name (or ID) and, for unregistered users, enter their email 

address. Alternatively, click the Select User button, then click the + button next to the desired user in the org chart, 
review the selection, and click Apply. 

 Select registered users on Wrapsody eCo 
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When entering a user ID in the input field, a list of registered users will appear for selection. 

 Select unregistered users on Wrapsody eCo 
Enter the user’s email address and press the Enter key. 

Note: To remove a user from Selected, click the Delete icon  next to their name. 
10. Enter the message for the workgroup creation notification in the Notification email message input field (optional). 
11. Click Workgroup Permissions to set the default file permissions for members, then OK (optional). 
12. Click Share. 
13. A new workgroup is created, and files are uploaded to it at the same time. 

Route 2. User PC 

You can share files to a new workgroup. 

Note: Files with unsupported extensions for wrapping will be shared in their original format. Refer to supported 
applications and file formats. 

1. Right-click the file you want to share to a workgroup on your PC. 
2. Click Wrapsody eCo > Share files to Workgroup. 
3. Click the Wrapsody eCo site where you want to upload the file. If the login window appears, log in. 
4. Click Next. 
5. In the Share File to Workgroup window, review the files to be shared and click Next. 

Note: To delete a file, click the Delete icon  next to it. 
6. The Select Workgroup window will appear. 
7. Select Share to New Workgroup. 
8. Enter a Workgroup name. 
9. In the Workgroup members input field, enter the user’s name (or ID) and, for unregistered users, enter their email 

address. Alternatively, click the Select User button, then click the + button next to the desired user in the org chart, 
review the selection, and click Apply. 

 Select registered users on Wrapsody eCo 
When entering a user ID in the input field, a list of registered users will appear for selection. 

 Select unregistered users on Wrapsody eCo 
Enter the user’s email address and press the Enter key. 

Note: To remove a user from Selected, click the Delete icon  next to their name. 
10. Enter the message for the workgroup creation notification in the Notification email message input field (optional). 
11. Click Workgroup Permissions to set the default file permissions for members, then OK (optional). 
12. Click Share. 
13. Once the upload to the selected workgroup is complete, a Shared to Workgroup window will appear, and the local 

file will be encrypted. 

Add members to a workgroup 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the workgroup’s Home tab. 
4. Click on the Add member button in the top-right corner. 

Note: Members can also be added using an alternative method. Navigate to the Workgroup page, and find a list of 

workgroups. Click on the More button  for a certain workgroup, go to Workgroup Details > Manage member, and 

finally click on the Add member button  at the top. 
5. The Add member pop-up window will appear. 
6. Add workgroup members. There are three ways to add workgroup members. 

 Search in the search bar (for internal users) 
Type a user name or email address (ID) in the search box, then click to select the user.  
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 Enter an email address (for external users) 

Type the external user's email address in the search bar, then press Enter. 

 
 Select from the list of internal or external users (for internal or external users already added to the org chart) 

Click once in the search bar, then select either Find in the list of internal users or Find in the list of external 
users from the dropdown menu. Select a user from the list that appears, then click OK.  

 
7. Confirm the member you want to add and click OK. 

 Hover over the member icons to the left of the Add member button to view the members as follows: 

 
 Click on the member icons to the left of the Add member button to see the detailed member list and the head 

of workgroup. 

Resend invitations to members 
In a workgroup, members can resend invitation emails to users who have not yet joined Wrapsody eCo after being invited. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Home tab of the workgroup. 
4. Click on the member icons to the left of the Add member button. 

 
5. In the Member window, click on the Not registered text next to the members who have not joined in the workgroup 

yet. 
6. An invitation email will be sent to the respective member. 

Remove members from workgroups 
The head of a workgroup can remove members from the workgroup. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Home tab of the workgroup. 
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4. Click on the member icons to the left of the Add member button. 

 

5. In the Member window, click on the More button  next to the member to be removed from the workgroup. 
6. Click on Remove, and the member will be immediately removed from the workgroup. 

Change the head of a workgroup 
The head of a workgroup can transfer their admin privilege to another member of the workgroup. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Home tab of the workgroup. 
4. Click on the member icons to the left of the Add member button. 

 

5. In the Member window, click on the More button  next to the member to whom you want to transfer admin 
rights. 

6. Click on Change workgroup head, and the admin rights will be immediately transferred to that member. 
Note: Admin rights can also be transferred using an alternative method. In the Home tab of the workgroup, click the 

More button , then navigate to Workgroup Details > Manage member, and finally click on Change workgroup 
head for a certain member in the list. 

Create folders in a workgroup 
You can create folders in your workgroup to manage the files in a more organized way. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Click the File tab. 
4. Navigate to the location where you want to create a folder. 
5. Click the Create Folder button in the top-right corner.  
6. In the Create Folder window that appears, enter a name for the folder and click OK. 
7. A folder will be created in the current location. 

Rename folders in a workgroup 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Click the File tab. 
4. Right-click a folder to rename. 
5. Select Rename. 
6. Type a new name and click OK. 

Star & unstar workgroups  

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 

 Star a workgroup 

In the Home tab of the workgroup, click on the Star icon  to the right of the workgroup name, or select Star 

from the More menu  located in the top right corner. 
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 Unstar a workgroup 

In the Home tab of the workgroup, click on the Unstar icon  to the right of the workgroup name, or select 

Unstar from the More menu  located in the top right corner. 
3. The workgroup will be added to or removed from your Starred tab. 

Delete folders in a workgroup 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Click the File tab. 
4. Right-click a folder to delete. 
5. Click on Delete. 
6. When the Delete folder confirmation window appears, click Delete. 
7. The folder will disappear. 

Note: When deleting a folder, any files contained within it will also be deleted. Deleted files can be restored from the 
Trash section. However, when restoring files that were within a folder, the deleted folder itself will not be restored. 

Leave workgroups 
Members who are not the workgroup head can leave the workgroup. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 

3. Choose Leave from the More menu  at the top right corner. 
4. Review the contents in the confirmation window and click on Leave Workgroup. 
5. The workgroup will disappear from your workgroup list. 

Delete workgroups 
Workgroup heads have the ability to delete the workgroup. Once deleted, access to files downloaded from that 
workgroup will be restricted. If needed, you can request workgroup restoration to the Wrapsody eCo administrator. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 

3. Click on the Workgroup Details button  to the right of the workgroup name, or select Workgroup Details from 

the More menu  at the top right corner. 
 

4. In the Basic info tab, click on the Delete workgroup button. 
5. Review the contents in the confirmation window and click on Delete workgroup. 
6. The workgroup will be removed from your workgroup list. 

Check workgroup usage history 
You can view the history of workgroup management, file usage and management, video conferencing, and chats by type 
and date. 

Route 1. Web 
Note: For changes such as permissions or ownership, hovering over the history item displays the current details. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the History tab. 
4. The entire history of the selected workgroup will appear as a list on the page. 
5. Use the filters at the top to specify the conditions for displaying the history (multiple selections allowed). 

 History type: Select the type you want to display, then click OK. 
 Date: Select the period that includes the date when actions occurred. Alternatively, click Custom, specify the 
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desired period directly, and click OK. 
6. Histories matching the specified conditions will be displayed. 

Note: Clicking on each history will display detailed information about the corresponding file, workgroup, or video 

conference on the right side. For files, hovering over and clicking on the More icon  will provide functions such as 
Open, Download, Share Link, File Permissions, and View Request. For chat histories, hovering over and clicking on the 

Chat icon  will redirect you to the location of the corresponding message in the Chat tab. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 
3. Navigate to the History tab. 

Note: Hovering over file usage and management histories and clicking the Download button  allows you to download 
the corresponding file. 

Configure workgroups 

The workgroup head can manage workgroup settings. 

Add workgroup descriptions 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. In the Home tab of the workgroup, click Add workgroup description right below the workgroup name.  
4. Enter a description in the Description window, then click OK. 

Note: Alternatively, click the Workgroup Details button  to the right of the workgroup name, then press the Edit 
button on the Basic info tab, and enter a description in the Description field. Once you press Save changes, the entered 
description will be applied. You can modify the description using the same method. 

Rename workgroups 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Home tab of the workgroup. 

4. Select Rename Workgroup from the More menu  at the top right. 
5. After making the desired changes to the name, click the OK button. 

Note: Alternatively, click the Workgroup Details button  to the right of the workgroup name, then press the Edit 
button on the Basic info tab, and modify the name under the Workgroup name heading. Once you press Save changes, 
the modified name will be applied. 

Set permissions to invite to a workgroup 
Restrict the ability to invite other users to the workgroup. 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 

3. Click the Workgroup Details button  to the right of the workgroup name, or select Workgroup Details from the 

More menu  in the top-right corner. 
4. Select the Basic settings tab. 

5. In the Invitation permission allowed to section, click the dropdown button  and select the desired option: 
 Workgroup head 
 Internal user 
 All users 

6. Click the Save button. 
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Set valid periods for a workgroup 
Specify the duration for which you want this workgroup to remain valid. After the duration is over, only the head of the 
workgroup will have access, and the workgroup will not be visible to its members. The head of workgroup can choose to 
either delete an expired workgroup or extend its valid duration. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 

3. Click the Workgroup Details button  to the right of the workgroup name, or select Workgroup Details from the 

More menu  in the top-right corner. 
4. Select the Basic settings tab. 

5. In the Workgroup is valid section, click the dropdown button  and select a valid period. 
6. Depending on the selected time period, the end date will be indicated below. However, if you select Custom, select 

an expiration date from the calendar, and then click Apply. 
7. Click the Save button. 

Manage share link types and properties for workgroup files 
By default, the share link type and properties for workgroup files are determined by the organization's policy (modifiable 
only by the Wrapsody eCo administrator). Workgroup heads can adjust these default settings, but changes only apply to 
files uploaded after the update. 

Set default share links to anonymous 

You can set the share link for workgroup files to an anonymous type. For anonymous links, you can restrict the allowed 
file usage options to Preview only, Download only, or Preview & Download. 
Note: Users accessing an anonymous link can use the file without logging into Wrapsody eCo. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 

3. Click the Workgroup Details button  to the right of the workgroup name, or select Workgroup Details from the 

More menu  in the top-right corner. 
4. Select the Basic settings tab. 
5. In the Share link section, select Anonymous. 

6. Click the dropdown button , and select the file usage option allowed through the link: Preview only, Download 
only, or Preview & Download. 

7. Select the Set expiration date option and enter the number of days the file will be accessible from the upload date 
(optional). 

8. Click the Save button. 

Set default share links to authenticated 

You can set the share link for workgroup files to an authenticated type. 
Note: Users with access to an authenticated link can use the file after logging into Wrapsody eCo, according to the 
permissions granted. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 

3. Click the Workgroup Details button  to the right of the workgroup name, or select Workgroup Details from the 

More menu  in the top-right corner. 
4. Select the Basic settings tab. 
5. In the Share link section, select Authenticated. 
6. Click the Save button. 
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Set permissions for a workgroup 

For workgroup files without user-specific permissions, the permissions set in the Workgroup Permissions section apply 
to all members by default. For files with user-specific permissions, only members with Workgroup Permissions will be 
granted the permissions set for the workgroup. 
Note: To assign custom permissions for individual members, refer to the Check and change custom permissions for users 
section. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 

3. Click the Workgroup Details button  to the right of the workgroup name, or select Workgroup Details from the 

More menu  in the top-right corner. 
4. In the Workgroup Details window, select the Workgroup Permissions tab. 

 
Note: If no changes have been made to Workgroup Permissions after the workgroup is created, the Default 
workgroup permissions specified in the General Policy will automatically apply. (General policies can be configured 
by the Wrapsody eCo administrator.) 

5. You can enable features such as file editing, downloading, and viewing restrictions for workgroup files: 
 File revision: Users with Workgroup Permissions can edit files uploaded to the workgroup. 
 File download: Users with Workgroup Permissions can download files uploaded to the workgroup. If this 

feature is disabled, downloads will not be allowed, and previously downloaded files will become unusable. 
- Protect (File encryption): When File download is enabled, files are encrypted during download to enhance 
security. Selecting Basic in the dropdown allows encrypted files to be downloaded and enables tracking of file 
usage. Selecting Advanced specifies which additional security features (e.g., Print, Screen capture, Copy & 
paste) are permitted for the downloaded encrypted files. 

 File view restriction: Limits can be set on the number of times and the period during which users with 
Workgroup Permissions can view files. If either the view count or the validity period is reached or expires, 
further file viewing is not allowed. 
- View count: Specify the maximum number of times a file can be viewed. This count is reduced each time an 
encrypted file is opened locally or previewed on the web. Files downloaded as non-encrypted files are not 
tracked, so the view count is not affected. 
- Validity period: Specify the number of days the file can be viewed starting from the upload date. This 
restriction applies to both encrypted files opened locally and files previewed on the web. It does not apply to 
non-encrypted files, as viewing activity cannot be tracked. 

 Web support: Users can open and edit files in a web browser. 
- Screen watermark applied: Choose whether to display a screen watermark on the web interface. 
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 Mobile support: Users can view or edit files on mobile devices. 
 Mac support: Users can view or edit files on Mac devices. 

Note: The availability of Screen Watermark (Web Support), Mobile Support, and Mac Support can only be 
checked, not configured. These options are determined by the organization's subscription plan. The site owner 
can enable or disable them within the limits of the plan's support, and users cannot modify these settings. 

 View permission to internal users: View permission to internal users: Internal users within the organization 
who are not members of the workgroup can be granted access to view workgroup files. 
Note: The workgroup head can enable the View permission to internal users feature, regardless of the default 
settings from the Wrapsody eCo administrator. If internal users outside the workgroup view a file, it will not be 
recorded in the workgroup history. In addition, in the Details window for a specific file on the client side, the 
Add bookmark, Preview, Download, Share link, File Permissions, and View Request buttons, along with the 
comment input field, will not be displayed. In the right pane of the window, the File permissions and Folder 
name headings, along with their correspondent information, will not be displayed as well. When opening a file 
on the web interface as well, the comment input field in the Comment tab, as well as the File permissions and 
Folder name headings and their correspondent information in the Details tab, will not be visible. 

6. Click Save to reflect your edits. 

Extend the workgroup deadline 

Expired workgroups can either be deleted or continue to be available after the deadline is prolonged within a month of 
the original expiration date. The workgroup will be automatically deleted one month after the expiration date. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. If you select an expired workgroup, the Workgroup Expired pop-up window appears. 
4. Clicking the Extend button will take you to the Workgroup Details page. 
5. Modify the expiration date of the workgroup, and then click Apply. 

Collaborate on files 
Workgroup members can access uploaded files in the File tab of the workgroup, and they can also utilize files sent through 
the sending feature in My Inbox. 

Download files 
You can download and open the latest version of files on your PC. Please note that files can only be opened on the your 
PC if the Wrapsody eCo client is installed. 

Note: Depending on the company policy, files may also be downloaded in HTML wrapping file format. In an environment 
with the Wrapsody eCo client installed, opening an HTML file converts it to a Wrapsody eCo file. In the absence of the 
client, it opens in a web browser and prompts the installation of the Wrapsody eCo client. 

Route 1. Web (Workgroup) 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. Right-click a file and select Download. 
5. The file will be downloaded to your PC at the default or specified location. 
Note: To download multiple files, select the checkboxes of the files, then click the Download button activated in the top 
right corner. 

Route 2. Web (My Inbox) 
1. Go to the Wrapsody eCo website. 
2. Select either the Sent or Received tab in the My Inbox section. 
3. Right-click a file and select Download. 
4. The file will be downloaded to your PC at the default or specified location. 
Note: To download multiple files, select the checkboxes of the files, then click the Download button activated in the top 
right corner. 
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Route 3. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 

3. In the File tab, hover over a file and click on the More button . 
4. Select Download. 
5. The file will be downloaded to your PC at the default or specified location. 

Download files by version 
You can download previous versions of files. Please note that files can only be opened on your PC if the Wrapsody eCo 
client is installed. 

Route 1. Web (Workgroup) 
1. Go to the Wrapsody eCo website. 
2. Select a workgroup in the Workgroup section and navigate to its File tab. 
3. Click on the area of the file for which you want to view details (excluding the name) to show detailed information on 

the right pane. 
Note: Clicking on the file name opens the file preview in a web browser. In the browser, clicking on the Details tab

 on the right also expands the Details pane. 

4. In the File history section, hover over the desired file version and click the Download icon . 

Route 2. Web (My Inbox) 
1. Go to the Wrapsody eCo website. 
2. Select either the Sent or Received tab in the My Inbox section. 
3. Click on the area of the file for which you want to view details (excluding the name) to show detailed information on 

the right pane. 
Note: Clicking on the file name opens the file preview in a web browser. In the browser, clicking on the Details tab

 on the right also expands the Details pane. 

4. In the File history section, hover over the desired file version and click the Download icon . 
 

Route 3. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 

3. In the File tab, hover over a file and click on the More button . 
4. Select Details. 

5. In the File history section, hover over the desired file version and click the Download icon . 
 

Route 4. User PC path 
1. Right-click on a Wrapsody eCo file downloaded on your PC. 
2. Select Wrapsody eCo > Details. 

3. In the File history section, hover over the desired file version and click the Download icon . 

Download decrypted files 
The file owner or sender can download a Wrapsody eCo file as a non-encrypted file. Workgroup members who are not 
file owners or recipients can download files in a decrypted format only when the file owner or sender has disabled the 
Protect (File encryption) feature for that user. 

Case 1. File owner 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page and select the File tab. Or select the 

Sent tab in the My Inbox section. 
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3. Hover over a file and click the More icon . 
4. Click Decryption download (only visible to file owners) to decrypt and download the file. 

Note: By default, file permissions for the file owner or sender are set to allow downloading only encrypted files. Therefore, 
the file owner or sender can only download non-encrypted files through Decryption download. 

Case 2. Non-file owner 

Files with Protect (File encryption) disabled, either through workgroup permissions or user-specific permissions, will be 
decrypted and available for download as plain files. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page and select the File tab. Or select the 

Sent tab in the My Inbox section. 

3. Hover over a file and click the More icon . 
4. Click Download to decrypt and download the file. 

Preview files 
You can open files in a web browser for previewing. 
Note: Viewing files in preview mode will be recorded as File viewed in the history. 

Route 1. Web (Workgroup) 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the File tab. 
4. Click on the name of a file, or right-click on it and select Open. 
5. The file preview will open in the web browser. 

Route 2. Web (My Inbox) 
1. Go to the Wrapsody eCo website. 
2. Select either the Sent or Received tab in the My Inbox section. 
3. Click on the name of a file, or right-click on it and select Open. 
4. The file preview will open in the web browser. 

Route 3. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 
3. Click on the name of a file in the File tab. 
4. The file preview will open in the web browser. 

View files 
In addition to viewing file previews in a web browser, users can also to open files using their dedicated applications on 
their PCs. 
1. Double-click on the Wrapsody eCo file downloaded on your PC. 
2. In the open mode selection dialog box, click the View button. 

Check out & check in files (User PC) 
This process involves users with file editing permissions registering a new version on the Wrapsody eCo server after 
editing a file. To edit files other than MS Office or TEXT files, or to modify encrypted Wrapsody eCo files using dedicated 
applications, the Wrapsody eCo client must be installed. If you do not have file edit permissions, you can request edit 
permissions directly from the file owner or workgroup head. If a file has already been checked out or is being edited by 
another user, it cannot be opened in Revise mode. 

Note: Wrapsody eCo Cloud allows direct editing of MS Office files after logging in with M365 credentials, but for 
Wrapsody eCo, you need to consult with Fasoo sales representatives to enable the editing feature. If you intend to open 
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files using other applications, please contact your administrator. 

1. Double-click on the Wrapsody eCo file downloaded on your PC. 
2. In the open mode selection dialog box, click the Check Out button. 
3. Modify the content in the dedicated program (optional). 
4. Save and close the file. 
5. In the dialog box prompting to check in the file, enter comments for the new version or choose whether to send a 

notification to users with file access permissions regarding the creation of the new version. Then click Check in. 

Hold check-in (User PC) 
When a user puts a check-in on hold after editing and saving a Wrapsody eCo file on their PC, the modifications are saved 
only on the user's PC, and they are not registered as a new version on the Wrapsody eCo server. 

1. Double-click on the Wrapsody eCo file downloaded on your PC. 
2. In the open mode selection dialog box, click the Check Out button. 
3. Modify the content in the dedicated program (optional). 
4. Save and close the file. 
5. In the dialog box prompting to check in the file, click Not Now. 

Note: If you check in a copy of an original file while holding the check-in of the original file, the original file will open in 
View mode. Any changes made will be saved locally on the PC and will not be uploaded to the server. In Wrapsody eCo 
Cloud, if you try to open the original file in Revise mode, a branch file will be created for it, preserving the original file 
while allowing revisions to be made separately. 

Edit on the web (Web revision) 
Users with file editing permissions can register a new version on the Wrapsody eCo server after editing a file in a web 
browser. Web revision supports primarily MS Office or TEXT files, although certain file extensions may be restricted 
depending on internal server settings. If you do not have file editing permissions, please request them directly from the 
file owner or workgroup head. 

Note: You cannot edit a file if another user has already checked it out. Additionally, depending on the web browser 
environment, revisions may still occur without pressing the save icon . 

Case 1. Workgroup 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. Click on the name of a file, or right-click on it and select Open. 
5. The file preview will open in the web browser. 
6. Select Edit in browser or Edit in [application name] in the top-right corner. 
7. Modify the content (optional). 
8. Click the Save icon  in the top left corner. 
9. Close the web browser. 
10. The saved content will be registered as a new version. 

Case 2. My Inbox 
1. Go to the Wrapsody eCo website. 
2. Select either the Sent or Received tab in the My Inbox section. 
3. Click on the name of a file, or right-click on it and select Open. 
4. The file preview will open in the web browser. 
5. Select Edit in browser or Edit in [application name] in the top-right corner. 
6. Modify the content (optional). 
7. Click the Save icon  in the top left corner. 
8. Close the web browser. 
9. The saved content will be registered as a new version. 
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Check out & check in files manually 
For workgroup files supporting manual revision, users with editing permissions can edit files using the manual revision 
feature and upload them to the server as the latest version. However, the file content can only be modified if the 
Wrapsody eCo client is installed. 

Note: The availability of the manual revision feature and supported file extensions (e.g., .dwg, .dxf, .nwd, .nwf, .nwc) may 
vary depending on the customer, so please consult your internal Wrapsody eCo administrator. 

Route 1. Web 

On the Wrapsody eCo website, you can check out and check in files. However, the client must be installed to open files 
downloaded to your PC for editing. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 

4. Hover over a file to revise and click on the More icon .  
5. Click on the Download button to download the file on your PC. 

6. Hover over the file on the web again and click on the More icon . 
7. Click on Manual Check-out from the menu. 
8. Open the downloaded file, edit it and save it. 

9. Hover over the file you finished editing, and click the More icon .  
10. Click on Manual Check-in. If you choose Cancel Check-out at this point, the modified file will only be saved on your 

PC and will not be updated on the server. 
11. When the Manual Check-in dialog box appears, drag and drop the revised file or select the file from your PC. 
12. If necessary, provide comments about the changes in the input box.  
13. Check the Notify all users with View permission option if you want to send notifications to all users with View 

permissions. 
14. Click Manual Check-in to complete the manual revision. 

Route 2. Client 

If the Wrapsody eCo client is installed, users can manually check in and out downloaded files on their PC. 

1. Download a Wrapsody eCo file on your PC. 
2. Right-click on the Wrapsody eCo file. 
3. Click on Wrapsody eCo > Details. 
4. Click the Manual Check-out button in the Details window. 
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5. Click OK when the Manual Check-out dialog box appears. 
6. Modify the file. 
7. Right-click on the Wrapsody eCo file. 
8. Click on Wrapsody eCo > Details again. 
9. Choosing Manual Check-in will register the modified file as the latest version on the server. Selecting Cancel Check-

out will store the modified file only on your PC without updating it on the server. 

Leave comments on a file 
You can leave comments on files and review the history of other users' comments, facilitating communication and 
collaboration among team members. 

Route 1. Web (Preview browser) 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page and select the File tab. Or select either 

the Sent or Received tab in the My Inbox section. 
3. Click on the name of a file, or right-click on it and select Open. 
4. The file preview will open in the web browser. 

5. Click on the Comment tab  on the right sidebar. 
6. The Comment pane will expand. 
7. Enter your comment and click OK. 
8. Your comment will be added below. 
 

Route 2. Web (File Permissions page) 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 

4. Hover over a file and click the More icon . 
5. Click on File Permissions. 
6. Click on Comment at the bottom. 
7. The Comment window appears. 
8. Enter your comment and click OK. 
9. Your comment will be added below. 

Route 3. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
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2. Click on the icon of your desired workgroup in the list on the left side. 

3. In the File tab, hover over a file and click on the More button  > Details. 
Note: You can also directly open the Details window from the Wrapsody eCo file downloaded to your PC. Right-click 
on the file and select Wrapsody eCo > Details. 

4. Enter your comment in the Comment section and click OK. 
5. Your comment will be added at the bottom. 

Utilize the AI document analysis feature 
AI Assistant analyzes Wrapsody eCo documents within your workgroup using AI technology. You can freely ask AI 
Assistant questions about the document and easily obtain answers. 

Note: AI Assistant can analyze up to five documents simultaneously. It supports various text files including MS Office, 
Hangul, PDF, and TEXT files. 

Route 1. Web 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. Select the checkbox next to the document you want to analyze (multiple selections allowed). 
5. Click on the AI Assistant button at the top right. 
6. The AI Assistant window will appear with the selected document. You can drag and drop additional documents to 

add them. 
7. Click on guiding questions or type your question directly and press Enter. 
8. AI Assistant will generate and provide answers. 

Note: You can also open the AI Assistant window by clicking the AI Assistant button  at the bottom right in the File 
tab. You can then drag and drop documents to add them. 

Route 2. Web (Preview browser) 
You can utilize AI Assistant within the document preview window as well. However, please note that you can only pose 
questions related to the specific document being previewed, and you cannot add additional documents for analysis. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. Click on the name of a document. 
5. The document preview window will open. 

6. Click on the AI Assistant tab  on the right sidebar. 
7. The AI Assistant pane will expand. 
8. Click on guiding questions or type your question directly and press Enter. 
9. AI Assistant will generate and provide answers. 

Manage files 
You can manage workgroup files or files shared through the file sending feature. 

Search for files 

Route 1. Web 
1. Go to the Wrapsody eCo website. 
2. Type a file name in the search box at the top and press Enter. 

 
3. Files and video conferences containing the search term will be displayed. 
4. Use the filters at the top to narrow down the search results. 
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 Type: Select File as the target type and click OK. 
 Workgroup: Specify the area to search for files. Select multiple workgroups, including My Inbox, and click Apply. 
 Owner: Enter the file owner of files, select the corresponding file owner from the results, and click Apply. 
 Last 1 month: Select the period when updates occurred. After selecting Custom, you can specify the period 

directly. 

 Last update: Click the down arrow  to choose the sorting criteria and order for files. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 

2. Click on the Search icon . 
3. Enter your search term and press Enter. 
4. Files and video conferences containing the search term will be displayed. 

5. Use the filter  at the top to narrow down the search results. 
 Type: Select File as the target type and click OK. 
 Date: Select the period when updates occurred. After selecting Custom, you can specify the period directly. 

 Last update: Click the down arrow  to choose the sorting order of the files. 

View a file list categorized by type 
You can categorize and view workgroup files based on their types. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. Click on Filter at the top right corner. 
5. Select each item and set conditions to display only the files that meet those conditions. 

 File type: All, Starred, Owned by me, Unopened 
 Date: Choose the period during which updates occurred. After selecting Custom, you can specify it directly. 
 View Request: Only displays a list of files for which you have received view alerts. 

Check file details 
In the Details section for a file, you can access the following information. Please note that some items may not be 
provided for files exchanged via the My Inbox send feature. 

Item Description 

File name 
File size · File type 

 

Member icon  The profile icons representing workgroup members or file senders. 

Workgroup 
The name of the workgroup to which the file belongs, along with the corresponding 
workgroup icon. 

File permissions 
My usage permission for the file. Usage permissions are displayed as either File owner, 
Workgroup permissions, Personal permissions, or No permission. 

Last update The date and time when the most recent version was created. 

Created  The date and time when the Wrapsody eCo file was created. 
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Folder name The name of the folder where the file is located in the workgroup. 

File history 

The list of all versions, along with the volume and creation date of each version. 
You can click the icons that appear when you hover over each version either to download 
the version or view its usage history. 

Download icon : Downloads the Wrapsody eCo file of the version to your PC.  

Down arrow : Reveals the history of file usage and management, including actions 
such as viewing, revising, changing permissions for each version, along with the time and 
date when the action occurred. 

The file details window can be accessed via the following paths: 

Route 1. Web (Workgroup) 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page and select the File tab. 

Click on the area of the file for which you want to view details (excluding the name) to show detailed information on 
the right pane. 
Note: Clicking on the file name opens the file preview in a web browser. In the browser, clicking on the Details tab

 on the right also expands the Details pane. 

Route 2. Web (My Inbox) 
1. Go to the Wrapsody eCo website. 
2. Select either the Sent or Received tab in the My Inbox section. 
3. Click on the area of the file for which you want to view details (excluding the name) to show detailed information on 

the right pane. 
Note: Clicking on the file name opens the file preview in a web browser. In the browser, clicking on the Details tab

 on the right also expands the Details pane. 

Route 3. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 

3. In the File tab, hover over a file and click on the More button  > Details. 

Route 4. User PC 
1. Right-click on a Wrapsody eCo file downloaded on your PC. 
2. Select Wrapsody eCo > Details. 

Check & change permissions for users 
File owners can assign different permissions to users for a file. The available permissions include File owner permissions, 
Workgroup permissions for workgroup members, Personal permissions assigned by the file owner, and No permission. 
While the workgroup h can modify the file owner, they cannot set file permissions. 

User permission types 

 File owner: The file owner's permissions are fixed and can only be set by an administrator. Detailed permission 
information can be viewed by hovering over the permission. 
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 Workgroup permissions: These permissions are set in the Workgroup Details window. 
 Personal permissions: These are customized permissions granted by the file owner to individual users. 
 No permission: Users with No permission cannot access the file. 

Route 1. Web (Workgroup) 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 

4. Hover over a file and click the More icon . 
5. Select File Permissions from the menu. 
6. The list of the file owner and members will appear, allowing you to view the permissions granted to each member. 
7. Hover over each permission to view the sub-permissions currently included in the corresponding permission type. 
8. To change a user's permissions, click on the current permission and select from File owner permissions, Workgroup 

permission, Personal permission, and No permission. If selecting Personal permission, modify the specific 
permissions and click OK. 

Route 2. Web (Set permissions for multiple files) 
You can bulk modify permissions for each user for all files within a workgroup. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. In the list of files, select the checkboxes of the files you want to set the same permissions for. 

5. Click the More icon  that will be enabled in the top right corner. 
6. Select File Permissions.  
7. The Permissions to multiple users for the file window appears. 
8. The list of the file owner and members will appear, allowing you to view the permissions granted to each member. 
9. Hover over each permission to view the sub-permissions currently included in the corresponding permission type. 
10. To change a user's permissions, click on the current permission and select from File owner permissions, Workgroup 

permissions, Personal permissions, and No permission. If selecting Personal permission, modify the specific 
permissions and click OK. 

Route 3. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 

3. In the File tab, hover over a file and click on the More button  > Details. 
Note: Yon can also open the Details window from a Wrapsody eCo file downloaded on your PC. Right-click on the 
file and select Wrapsody eCo > Details. 

4. Click the File Permissions button . 
5. To change a user's permissions, click on the current permission and select from File owner permissions, Workgroup 

permissions, Personal permissions, and No permission. If selecting Personal permission, modify the specific 
permissions and click OK. 

Check & change custom permissions 
File owners or senders can assign different permissions for each workgroup ember or recipient. The user’s individual 
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settings window displays the default values from the Workgroup permissions settings. Settings can be customized for 
each member or recipient. 

 
You can restrict file editing, downloading, and viewing for each user on workgroup files or sent files: 

 File revision: Users can edit files uploaded to the workgroup. 
 File download: Users can download files uploaded to the workgroup. If this feature is disabled, downloads will not 

be allowed, and previously downloaded files will become unusable. 
- Protect (File encryption): When File download is enabled, files are encrypted during download to enhance security. 
Selecting Basic in the dropdown allows encrypted files to be downloaded and enables tracking of file usage. Selecting 
Advanced specifies which additional security features (e.g., Print, Screen capture, Copy & paste) are permitted for 
the downloaded encrypted files. 

 File view restriction: Limits can be set on the number of times and the period during which users can view files. If 
either the view count or the validity period is reached or expires, further file viewing is not allowed. 
- View count: Specifies the maximum number of times a file can be viewed. This count is reduced each time an 
encrypted file is opened locally or previewed on the web. Files downloaded as non-encrypted files are not tracked, 
so the view count is not affected. 
- Expiration: Specifies the date when file access will expire. 

 Web support: Users can open and edit files in a web browser. 
- Screen watermark applied: Choose whether to display a screen watermark on the web interface. 

 Mobile support: Users can view or edit files on mobile devices. 
 Mac support: Users can view or edit files on Mac devices. 

Note: The availability of Screen Watermark (Web Support), Mobile Support, and Mac Support can only be checked, 
not configured. These options are determined by the organization's subscription plan. The site owner can enable or 
disable them within the limits of the plan's support, and users cannot modify these settings. 

 View permission to internal users: View permission to internal users: Internal users within the organization who 
are not members of the workgroup can be granted access to view workgroup files. 
Note: The workgroup head can enable the View permission to internal users feature, regardless of the default 
settings from the Wrapsody eCo administrator. If internal users outside the workgroup view a file, it will not be 
recorded in the workgroup history. In addition, in the Details window for a specific file on the client side, the Add 
bookmark, Preview, Download, Share link, File Permissions, and View Request buttons, along with the comment 
input field, will not be displayed. In the right pane of the window, the File permissions and Folder name headings, 
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along with their correspondent information, will not be displayed as well. 

The Personal permission window for a specific file can be accessed via the following paths: 

Route 1. Web (Workgroup) 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 

4. Hover over a file and click the More icon . 
5. Select File Permissions. 
6. Click on the current permission of the user to modify individual permissions for them. 
7. Select Personal permissions. 
8. Adjust permissions in the individual user settings window. 
9. Click the OK button. 

Route 2. Web (My Inbox) 

You can restrict file permissions for recipients individually for files shared via the file send feature in My Inbox. 

1. Go to the Wrapsody eCo website. 
2. Select the Sent tab in the My Inbox section. 

3. From the list of files, hover over the file you want to configure permissions for, and the More icon  will be 
activated on the right. 

4. Select File Permissions. 

5. The list of file recipients is displayed, and hovering over the Settings icon  on the right of a user reveals the user's 
permissions for the file. 

6. Click the Settings icon. 
7. Adjust permissions in the individual user settings window. 
8. Click the OK button. 

Route 3. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 

3. In the File tab, hover over a file and click on the More button  > Details. 
Note: Yon can also open the Details window from a Wrapsody eCo file downloaded on your PC. Right-click on the 
file and select Wrapsody eCo > Details. 

4. Click the File Permissions button . 
5. Click on the current permission of the user to modify individual permissions for them. 
6. Select Personal permissions. 
7. Adjust permissions in the individual user settings window. 
8. Click the OK button. 

Send files 
You can manage sent and received files as Wrapsody eCo files in My Inbox. 

Route 1. Web (My Inbox) 

1. Go to the Wrapsody eCo website. 
2. Navigate to My Inbox > the Sent tab. 
3. Drag and drop a file from your PC onto the Sent page. 

Note: Alternatively, click New in the top right corner. Select the desired file in the file selection window, then click 
Open, or drag and drop the file from your PC. If there are additional files to send, click Upload to select additional 
files. 

4. Check the files that have been added to the list and click Next. 
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5. In the Recipients input field, enter the user's name (or ID). For unregistered users, enter their email address. 
Alternatively, click the Select User button, select users from the organization chart by clicking the + button next to 
their names, review the selected recipients, and click Apply. 

6. Selected recipients will have default permissions applied as defined by general policies. To assign customized 
permissions, click Basic permissions next to the user, select Custom, and configure them accordingly. 
Note: To set permissions for multiple users simultaneously, select the desired users from the list of recipients, click 
Set Bulk Permissions, and either apply Basic or Custom permissions. 

7. Enter the message for the workgroup creation notification in the Notification email message input field (optional). 
8. Review the selected recipients and their permissions, then click the Send button at the bottom right corner. 
9. The files will be saved in the Sent section of My Inbox, and an email containing a file preview and download link is 

sent to the recipient's email address. 

Route 2. User PC 

1. Right-click on a file to send on your PC. 
2. Click Wrapsody eCo > Send files. 
3. Click the Wrapsody eCo server address to where you want to upload the file. If you see the login window, log in. 
4. Click Next. 
5. The Send File window will appear. 
6. Review the list of Files and click Next. 
7. In the Recipients input field, enter the user's name (or ID). For unregistered users, enter their email address. 

Alternatively, click the Select User button, select users from the organization chart by clicking the + button next to 
their names, review the selected recipients, and click Apply. 

8. Selected recipients will have default permissions applied as defined by general policies. To assign customized 
permissions, click Basic permissions next to the user, select Custom, and configure them accordingly. 
Note: To set permissions for multiple users simultaneously, select the desired users from the list of recipients, click 
Set Bulk Permissions, and either apply Basic or Custom permissions. 

9. Enter the message for the workgroup creation notification in the Notification email message input field (optional). 
10. Review the selected recipients and their permissions, then click the Send button at the bottom right corner. 
11. The files will be saved in the Sent section of My Inbox, and an email containing a file preview and download link is 

sent to the recipient's email address. 

Check sent files 
You can check files sent using the Send File feature. 

1. Go to the Wrapsody eCo website. 
2. Navigate to My Inbox > the Sent tab. 

Check received files 
You can check files received using the Send File feature. 

1. Go to the Wrapsody eCo website. 
2. Navigate to My Inbox > the Received tab. 

Copy files (Share to another workgroup) 
The file owner or sender can copy files uploaded to a workgroup or My Inbox to another workgroup. Files shared with 
another workgroup will have a new file ID. 

Case 1. Copy to an existing workgroup 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 

4. Hover over the file you want to copy to another workgroup, click the More button  > Share to Workgroup. 
Note: For multiple files, select the checkboxes next to the files and click the Share to Workgroup button at the top 
right. 
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5. Select Share to Existing Workgroup in the Select Workgroup window. 
6. Select the workgroup to share the file to and enter a message to be sent via notification email (optional). 
7. Click Share. 
8. The files will be uploaded to the selected workgroup, and the page will navigate to the File tab of that workgroup. 

Case 2. Copy to a new workgroup 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 

4. Hover over the file you want to copy to another workgroup, click the More button  > Share to Workgroup. 
Note: For multiple files, select the checkboxes next to the files and click the Share to Workgroup button at the top 
right. 

5. Select Share to New Workgroup in the Select Workgroup window. 
6. Enter a Workgroup name. 
7. In the Workgroup members input field, enter the user’s name (or ID) and, for unregistered users, enter their email 

address. Alternatively, click the Select User button, then click the + button next to the desired user in the org chart, 
review the selection, and click Apply. 

 Select registered users on Wrapsody eCo 
When entering a user ID in the input field, a list of registered users will appear for selection. 

 Select unregistered users on Wrapsody eCo 
Enter the user’s email address and press the Enter key. 

Note: To remove a user from Selected, click the Delete icon  next to their name. 
8. Enter the message for the workgroup creation notification in the Notification email message input field (optional). 
9. Click Workgroup Permissions to set the default file permissions for members, then OK (optional). 
10. Click Share. 
11. A new workgroup will be created, the files will be uploaded to that workgroup, and the page will navigate to the File 

tab of the new workgroup. 

Case 3. From My Inbox to a workgroup 
1. Go to the Wrapsody eCo website. 
2. Navigate to My Inbox > the Sent tab. 
3. Right-click on a file to copy in the file list. 
4. Select Copy. 
5. Select the checkbox of the workgroup where you want to paste the file from the workgroup list. 
6. Press the Copy button. 
7. The file will be uploaded to the selected workgroup, and you will be redirected to the File tab of the workgroup 

where the file was uploaded. 

Change file ownership 
The head of a workgroup or a file owner can change the owner of files within the workgroup. 

Route 1. Web 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. From the list of files, select the files you want to change the owner for (multiple selections allowed). 
5. Click the More button activated at the top right and select Change file owner. 
6. When the Change file owner window appears, select the desired new file owner and click Change owner. 

Route 2. Web (File Permissions window) 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. Right-click on a file to change its file ownership. 
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5. Select File Permissions. 
6. The list of the file owner and members will appear, allowing you to view the permissions granted to each member. 
7. Click the current permission of a specific user to change them as the new file owner. 
8. Select File owner, and the ownership will be transferred to the user immediately. 

Route 3. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 

3. In the File tab, hover over a file and click on the More button  > Details. 
Note: Yon can also open the Details window from a Wrapsody eCo file downloaded on your PC. Right-click on the 
file and select Wrapsody eCo > Details. 

4. Click the File Permissions button . 
5. Click the current permission of a specific user to change them as the new file owner. 
6. Select File owner, and the ownership will be transferred to the user immediately. 

Rename files 
You can rename Wrapsody eCo files. Changing the name of a file downloaded on your PC does not change the server-
side name. To change the server-side name, follow the instructions below: 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page and select the File tab. Or select the 

My Inbox > Sent tab in the section. 
3. Right-click on a file and select Rename. 
4. Enter the new file name and click the OK button. 

Send View requests 
You can send View requests to other users to view a specific file. View requests can be sent on a scheduled date or 
instantly. 

Route 1. Web 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. Right-click on a file to send its view request. 
5. Select View Request. 
6. The list of users with permission for the file will appear. 
7. Select the members to send the View request to. Clicking Select all will select all members. 
8. Enter a message to be sent along with the request (optional). 

9. Select the Setting icon  located in the top-right corner to set the sending time and whether to resend the request 
if the file is not viewed. Then click OK (optional). 

 Delivery time: Set the time when the view should be sent. 
- Real-time: View requests will be sent immediately. 
- Scheduled: View requests will be sent on the date you specify. When you select Scheduled, click the date 
below to select the date in your calendar that you want to send on. 

 Resend if not viewed: If the recipient does not check the file, you can choose how many days later the request 
should be resent. 
- Do not send: View requests will not be resent. 
- after N days: Select a day between 1-7 days. 

10. Click View Request. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 
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3. In the File tab, hover over a file and click on the More button  > Details. 
Note: Yon can also open the Details window from a Wrapsody eCo file downloaded on your PC. Right-click on the 
file and select Wrapsody eCo > Details. 

4. Select the View Request button  at the top. 
5. The list of users with permission for the file will appear. 
6. Select the member(s) to send the View request to. Clicking Select all will select all members. 
7. Enter a message to be sent along with the request (optional). 

8. Select the Setting icon  located in the top-right corner to set the sending time and whether to resend the request 
if the file is not viewed. Then click OK (optional). 

 Delivery time: Set the time when the view should be sent. 
- Real-time: View requests will be sent immediately. 
- Scheduled: View requests will be sent on the date you specify. When you select Scheduled, click the date 
below to select the date in your calendar that you want to send on. 

 Resend if not viewed: If the recipient does not check the file, you can choose how many days later the request 
should be resent. 
- Do not send: View requests will not be resent. 
- after N days: Select a day between 1-7 days. 

Set file share links 
To facilitate easier collaboration, you can share a link for previewing or downloading a file instead of attaching it directly. 
By default, sharing link types and attributes for workgroup files are determined by workgroup settings, and for sent files, 
they are defined by the organization’s general policies (modifiable only by Wrapsody eCo administrators). File owners or 
senders can adjust sharing link types and attributes for each file. 

Note: Each file has one sharing link regardless of type, and any changes to the settings are applied immediately. 

Set share links as anonymous 

You can set a file’s sharing link to Anonymous. For Anonymous links, you can restrict the allowable file usage options 
(e.g., Preview only, Download only, or Preview & Download). 
Note: Users who have access to an Anonymous link can use the file without logging into Wrapsody eCo. 

Route 1. Web (Workgroup) 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. Right-click a file, and select Share link. 
5. The Share link window will appear. 
6. Set File access to Anonymous. 

7. Click the dropdown menu  and choose the file usage options to allow via the link: Preview only, Download only, 
or Preview & Download. 

8. Enable Set password, enter a 1-4 digit number, and click Apply (optional). 
9. Enable Set expiration date, and choose an expiration date for the file (optional). 
10. Close the window by clicking the x button. 

Note: Click Copy Link to save the file’s sharing link to the clipboard. 

Route 2. Web (My Inbox) 
1. Go to the Wrapsody eCo website. 
2. Navigate to My Inbox > the Sent tab. 
3. Right-click a file. 
4. Select Share link. 
5. The Share link window will appear. 
6. Set File access to Anonymous. 

7. Click the dropdown menu  and choose the file usage options to allow via the link: Preview only, Download only, 
or Preview & Download. 
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8. Enable Set password, enter a 1-4 digit number, and click Apply (optional). 
9. Enable Set expiration date, and choose an expiration date for the file (optional). 
10. Close the window by clicking the x button. 

Note: Click Copy Link to save the file’s sharing link to the clipboard. 

Route 3. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 

3. In the File tab, hover over a file and click on the More button  > Details. 
Note: Yon can also open the Details window from a Wrapsody eCo file downloaded on your PC. Right-click on the 
file and select Wrapsody eCo > Details. 

4. Click the Share link button  at the top. 
5. The Share link window will appear. 
6. Set File access to Anonymous. 

7. Click the dropdown menu  and choose the file usage options to allow via the link: Preview only, Download only, 
or Preview & Download. 

8. Enable Set password, enter a 1-4 digit number, and click Apply (optional). 
9. Enable Set expiration date, and choose an expiration date for the file (optional). 
10. Close the window by clicking the x button. 

Note: Click Copy Link to save the file’s sharing link to the clipboard. 

Set share links as authenticated 

You can set a file’s sharing link to Authenticated. 
Note: Users who have access to an Authenticated link must log in to Wrapsody eCo and can use the file according to the 
permissions granted to them. 

Route 1. Web (Workgroup) 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. Right-click a file, and select Share link. 
5. The Share link window will appear. 
6. Set File access to Authenticated. 
7. Close the window by clicking the x button. 

Note: Click Copy Link to save the file’s sharing link to the clipboard. 

Route 2. Web (My Inbox) 
1. Go to the Wrapsody eCo website. 
2. Navigate to My Inbox > the Sent tab. 
3. Right-click a file. 
4. Select Share link. 
5. The Share link window will appear. 
6. Set File access to Authenticated. 
7. Close the window by clicking the x button. 

Note: Click Copy Link to save the file’s sharing link to the clipboard. 

Route 3. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 

3. In the File tab, hover over a file and click on the More button  > Details. 
Note: Yon can also open the Details window from a Wrapsody eCo file downloaded on your PC. Right-click on the 
file and select Wrapsody eCo > Details. 

4. Click the Share link button  at the top. 
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5. The Share link window will appear. 
6. Set File access to Authenticated. 
7. Close the window by clicking the x button. 

Note: Click Copy Link to save the file’s sharing link to the clipboard. 

Copy file share links 
For easier collaboration, you can share a link that allows others to preview or download the file instead of attaching it 
directly. The type and details of the share link depend on the settings configured by the file owner and sender. 

Route 1. Web (Workgroup) 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. Right-click a file, and select Share link. 
5. Clicking Copy Link saves the link address to the clipboard. 

Route 2. Web (My Inbox) 
1. Go to the Wrapsody eCo website. 
2. Navigate to My Inbox > the Sent tab. 
3. Right-click a file, and select Share link. 
4. Clicking Copy Link saves the link address to the clipboard. 

Route 3. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 

3. In the File tab, hover over a file and click on the More button  > Details. 
Note: Yon can also open the Details window from a Wrapsody eCo file downloaded on your PC. Right-click on the 
file and select Wrapsody eCo > Details. 

4. Click the Share link button  at the top. 
5. Clicking Copy Link saves the link address to the clipboard. 

Bookmark files 
You can bookmark frequently used files for easy access and find them quickly in Bookmarks. 

Route 1. Web 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 

4. When hovering over a file, the Add bookmark icon  or the Remove bookmark icon  will appear. 
5. Clicking the Add bookmark icon will bookmark the file, adding it to Bookmarks, while clicking the Remove icon will 

remove the file from Bookmarks. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 
3. Navigate to the File tab. 

4. When hovering over a file, the Add bookmark icon  or the Remove bookmark icon  will appear. 
5. Clicking the Add bookmark icon will bookmark the file, adding it to Bookmarks, while clicking the Remove bookmark 

icon will remove the file from Bookmarks. 

Route 3. User PC 

1. Right-click on a Wrapsody eCo file downloaded on your PC. 
2. Select Wrapsody eCo > Details. 
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3. When hovering over a file, the Add bookmark icon  or the Remove bookmark icon  will appear. 
4. Clicking the Add bookmark icon will bookmark the file, adding it to Bookmarks, while clicking the Remove bookmark 

icon will remove the file from Bookmarks. 

Move files within a workgroup 
File owners can move files to another path within a workgroup.  
Note: Depending on company policies, all workgroup members may also have the ability to move file paths within the 
workgroup. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. Select a file to move (multiple selections allowed). 
5. Click the Move to another folder button in the top right corner. For a single file, you can also right-click and select 

Move to another folder. 
6. In the Move to another folder window, select the destination folder and click OK. 
7. The files will be moved to the destination folder. 

Delete files from a workgroup 
File owners can delete files within a workgroup or their sent files within My Inbox. Deleted files are stored in the file 
owner's Trash and can be restored. 

Case 1. Workgroup 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Navigate to the File tab. 
4. From the list of files, select the files you want to change the owner for (multiple selections allowed). 
5. Click the More button activated at the top right and select Delete. 
6. The file will be deleted instantly. 
 

Case 2. My Inbox 

1. Go to the Wrapsody eCo website. 
2. Navigate to My Inbox > the Sent tab. 
3. From the list of files, select the files you want to change the owner for (multiple selections allowed). 
4. Click the Delete button in the top right. 
5. The file will be deleted instantly. 

Restore files from Trash 
File owners can restore deleted files from Trash. 

1. Go to the Wrapsody eCo website. 
2. Navigate to Trash. 
3. Select the checkbox of a file to restore (multiple selections allowed). 

4. Click the Restore button in the top right corner. For a single file, you can also click the Restore icon  after hovering 
over it. 

5. In the confirmation window, click the Restore button. 

Delete files permanently 
File owners can permanently delete files in Trash. 

1. Go to the Wrapsody eCo website. 
2. Navigate to Trash 
3. Select the checkbox of a file to delete permanently (multiple selections allowed). 

4. Click the Delete forever button in the top right corner. For a single file, you can also click the Delete forever icon  
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after hovering over it. 
5. In the confirmation window, click the Delete forever button. 

Check the To-Do list for each workgroup 
Within each workgroup, you can easily check for files that you have received View requests for but haven't viewed yet, 
unread chat messages, and today's scheduled meetings all at once. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Check the To-Do items on the Home tab. 

Decrypt (Unwrap) downloaded files 
File owners can decrypt Wrapsody eCo files downloaded to their PC, converting them into plain files. 

Note: Depending on the Wrapsody eCo administrator settings, workgroup heads may also decrypt Wrapsody eCo files. 

1. Right-click on a Wrapsody eCo file from your PC. 
2. Select Wrapsody eCo > Unwrap. 
3. The file will be converted into a plain file. 

Chats 
The Chat section within a workgroup enables real-time conversations and file sharing among its members. 

Note: Depending on the plan that your organization subscribes to, the chat feature may not be supported. 

Send messages 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Chat tab. 

4. Type a message, then press the Enter key or click the Send button  to send your message. 

Schedule message sending 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Chat tab. 

4. Type a message and click the Schedule message sending button  at the bottom.  
5. Choose how many minutes later you want the message to be sent. Click on Custom to directly set the date and time 

for sending the message. 
6. Click Done. 

Send files in the chat room 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Chat tab. 

4. Drag a file into the message input field, or click on the Attach file button  at the bottom to select a file to attach 
(multiple selections allowed). 

5. Click Open. 

Reply to messages 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Chat tab. 
4. Right-click on a message and click Reply. 
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5. Type your reply, then press the Enter key or click the Send button  to send it. 

Forward messages 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Chat tab. 
4. Right-click on a message and click Forward. 
5. If there are additional messages to forward, select them. 
6. Click Next. 
7. Choose the user or chat room to forward the message to. 
8. Click Forward. 

Add bookmarks to messages 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Chat tab. 
4. Right-click on a message and click Add bookmark. 
5. If there are other messages to bookmark, select their checkboxes. 
6. Click Add Bookmark. 
7. The message will be stored as a bookmark in the chat service. 

View the reply history 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Chat tab. 
4. Right-click on the message with a history of replies, and click History. 
5. The history of all messages linked through replies to the selected message will be shown. 

Zoom video meetings (In Wrapsody eCo Cloud only) 
To create, edit, and delete your Zoom meetings, connecting to your Zoom account is required. If you are not yet a member 
of Zoom, please sign up at https://zoom.us first and then access the related feature. 

Prior to your meeting, please ensure you have installed the Zoom application on your device. For PC users, the application 
can be downloaded via the following link: https://zoom.us/download. For mobile devices, you can download the Zoom 
app for iOS from the App Store or for Android from the Google Play Store. 

Link your Zoom account 
In Wrapsody eCo, Zoom meetings will be available after you link your Zoom account. 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Meeting tab. 
4. Click Schedule a Meeting. 
5. When the Agree to connect Zoom account window appears, click OK. 

 
6. Enter your Zoom ID and password, then click Sign In.  
7. In the OTP input window, enter the passcode sent to your email and click Confirm. 
8. Click Allow to allow access to your Zoom account. 

https://zoom.us/
https://zoom.us/download)
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Note: The Zoom account integration process may vary depending on the Zoom version. 

Check meeting schedule 

Route 1. Web 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Meeting tab. 
4. A list of upcoming meetings will be displayed. 

5. If you want to view the previous meetings, click the Upcoming dropdown button  and select Previous. 

 

6. Click a meeting title from the list, or hover over a meeting and click on the More button  > Details. 
7. You can find out more about the meeting. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 
3. Go to the Meeting tab. 
4. A list of upcoming meetings will be displayed. 

5. If you want to view the previous meetings, click the Upcoming dropdown button  and select Previous. 
6. You can check the status of each meeting. 

Schedule meetings 

Route 1. Web 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Meeting tab. 
4. Click the Schedule a Meeting button in the center of the screen or in the top-right corner. 
5. If your Zoom account is not linked, a Zoom integration consent window will appear. Click OK and complete the Zoom 

account linking process. 
6. You will be redirected to the Schedule page. 
7. Enter the topic, description, start time, duration, time zone, and password, and select whether to enable the waiting 

room. 
8. All workgroup members are selected as the meeting participants by default. You can unselect members as 

participants from the list if needed by unselecting the checkboxes of specific participants. 
9. Click OK to create the meeting. 
10. The newly added meeting will be shown in the Upcoming list, and emails including an invitation link will be sent to 

the selected members. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 
3. Go to the Meeting tab. 

4. Click the Schedule button . 
5. The Schedule page of the Wrapsody eCo website opens. 
6. If your Zoom account is not linked, a Zoom integration consent window will appear. Click OK and complete the Zoom 
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account linking process. 
7. Enter the topic, description, start time, duration, time zone, and password, and select whether to enable the waiting 

room. 
8. All workgroup members are selected as the meeting participants by default. You can unselect members as 

participants from the list if needed by unselecting the checkboxes of specific participants. 
9. Click OK to create the meeting. 
10. The newly added meeting will be shown in the Upcoming list, and emails including an invitation link will be sent to 

the selected members. 

Reschedule meetings 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Meeting tab. 
4. A list of upcoming meetings will be displayed. 
5. Click on the title of a video conference to modify, then click on Edit on the information page. Alternatively, hover 

over a video conference and select More button  > Edit. 
6. After making the necessary changes, click on OK. 

Share join links to meetings 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Meeting tab. 
4. Click on the name of the video conference for which you want to share the link. 
5. Click Invite to the right of the link in the Invite Link section. 

 
6. Click Copy to copy the meeting invitation message containing the join link and information. 

Search for meetings 

Route 1. Web 

1. Go to the Wrapsody eCo website. 
2. Type a file name in the search box at the top and press Enter. 

 
3. Files and video conferences containing the search term will be displayed. 
4. Use the filters at the top to narrow down the search results. 
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 Type: Select Meet as the target type and click OK. 
 Workgroup: Specify the area to search for meetings. Select multiple workgroups, and click Apply. 
 Owner: Enter a meeting host, select the corresponding host from the results, and click Apply. 
 Last 1 month: Select the period where meetings were created. After selecting Custom, you can specify the 

period directly. 

 Last update: Click the down arrow  to choose the sorting order of meetings. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 

2. Click on the search icon . 
3. Enter your search term and press Enter. 
4. Files and video conferences containing the search term will be displayed. 

5. Use the filter  at the top to narrow down the search results. 
 Type: Select Meet as the target type and click OK. 
 Date: Select the period where meetings were created. After selecting Custom, you can specify the period 

directly. 

 Last update: Click the down arrow  to choose the sorting order of meetings. 

Bookmark meetings 
You can bookmark video meetings for easy access and find them quickly in Bookmarks. 

Route 1. Web 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Meeting tab. 

4. When hovering over a video meeting, the Add bookmark icon  or the Remove bookmark icon  will appear. 
5. Clicking the Add bookmark icon will bookmark the meeting, adding it to Bookmarks, while clicking the Remove 

bookmark icon will remove the meeting from Bookmarks. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 
3. Go to the Meeting tab. 

4. When hovering over a video meeting, the Add bookmark icon  or the Remove bookmark icon  will appear. 
5. Clicking the Add bookmark icon will bookmark the meeting, adding it to Bookmarks, while clicking the Remove 

bookmark icon will remove the meeting from Bookmarks. 

Start meetings 
A meeting host can start the scheduled meeting anytime. 

Route 1. Web 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Meeting tab. 

4. Click on the title of the meeting you want to start, and click Start at the top. Alternatively, click the Start icon  
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that appears when you hover over the meeting title. Please note that the Start icon will only be visible to the meeting 
host. 

5. When you log into Zoom, the meeting starts immediately. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 
3. Go to the Meeting tab. 

4. Hover over a meeting and click the Start icon . 
5. When you log into Zoom, the meeting starts immediately. 

Cancel meetings 
A meeting host can cancel the scheduled meeting anytime. 
1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Meeting tab. 
4. Click on the title of the meeting you want to start, and click Delete at the top. Alternatively, hover over a meeting 

title, and select the More icon  > Delete. Please note that the Delete button will only be visible to the meeting 
host. 

Join meetings 
Members invited to a video conference in a workgroup can join the meeting directly from various platforms such as the 
Wrapsody eCo website, client application, etc. 

Route 1. Web 

1. Go to the Wrapsody eCo website. 
2. Click on your desired workgroup from the navigation menu to access its page. 
3. Go to the Meeting tab. 
4. Click on the title of a meeting to attend. 
5. Select the Join Meeting button in the top-right corner. 
6. Log in to Zoom and join the meeting. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 
2. Click on the icon of your desired workgroup in the list on the left side. 
3. Go to the Meeting tab. 

4. Hover over a meeting to attend and click the Join Meeting button . 
5. Log in to Zoom and join the meeting. 

Route 3. Email link 

1. Check for a meeting invitation email in your email inbox. 
2. Click the invitation link in the email. 
3. Log in to Zoom and join the meeting. 

Check notifications 
Users can review updates from the workgroups they belong to or from My Inbox in the notification center. 

Route 1. Web 

1. Go to the Wrapsody eCo website. 

2. Click on the notifications icon  in the top right corner of the screen. 
3. Notifications will appear in time order. 
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 Red dot : Indicates unread notifications among the newly arrived ones. 
 Mark all as read: Marks all notifications as read, removing the red dot  from all notifications. 

 Open  & Download : Hover over a file update notification, then click one of the buttons to preview or 
download the file. 

Route 2. Client 

1. Click on the Wrapsody eCo icon  in the system tray. 

2. Click on the notifications icon  at the top. 
3. Notifications will appear in time order. 

 
 Red dot : Indicates unread notifications among the newly arrived ones. 
 Mark all as read: Marks all notifications as read, removing the red dot  from all notifications. 

 Details  & Download : Hover over a file update notification, then click this button to view file details or 
download the file. 
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Manage your Wrapsody eCo account 

Check your profile 
1. Go to the Wrapsody eCo website. 
2. Click on the profile icon at the top right of the screen. 
3. Click on Manage account. 
4. In the Profile tab, verify your information, such as profile image, username, job title, and roles. 

Modify your profile (For external users only) 
External users of Wrapsody eCo can modify their profiles. 

1. Go to the Wrapsody eCo website. 
2. Click on the profile icon at the top right of the screen. 
3. Click on Manage account. 
4. In the Profile tab, click on the Edit button. 
5. Update your information, such as username, company affiliation, etc. 
6. Click the Change User Info button to save your changes. 

Change your password 
1. Go to the Wrapsody eCo website. 
2. Click on the profile icon at the top right of the screen. 
3. Click on Manage account. 
4. Go to the Change password tab. 
5. Click on the Edit button. 
6. Enter the new password and confirm password. 
7. Click on the Change password button. 

Manage your settings 

Manage third-party connections 
To use third-party apps with Wrapsody eCo services, you need to integrate the app with Wrapsody eCo. 

Link with third-party applications 
1. Go to the Wrapsody eCo website. 
2. Click on the profile icon at the top right of the screen. 
3. Click on Manage account. 
4. Go to the Apps to link tab. 
5. Click on the Link button next to the app you want to link with. 
6. Review the content in the consent window and click OK. 
7. Log in with your credentials. 
8. The app will be linked. 

Note: The third-party app integration process may vary depending on the app or its version. 

Unlink with third-party applications 
1. Go to the Wrapsody eCo website. 
2. Click on the profile icon at the top right of the screen. 
3. Click on Manage account. 
4. Go to the Apps to link tab. 
5. Click on the Unlink button next to the app you want to disconnect. 
6. The connection will be removed immediately. 

Note: The third-party app integration process may vary depending on the app or its version. 
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Set notifications 
You can configure the notifications you receive for Wrapsody eCo. 

1. Go to the Wrapsody eCo website. 
2. Click on the profile icon at the top right of the screen. 
3. Click on Set notifications. 
4. The Notifications tab in the Manage account window will open. 
5. Enable the items for which you want to receive notifications. 

Note: By default, email notifications are sent for enabled items. However, for File Update notifications, Revise also trigger 
mobile and PC push notifications. Additionally, Comment trigger mobile push notifications. 

Fix problems 

Wrapsody eCo client errors 
If you encounter any issues while using the Wrapsody eCo client, you can try to repair the software or reinstall the 
Wrapsody eCo client. 

Repair the client 
If you encounter problems while using Wrapsody eCo, you can repair the Wrapsody eCo client from the Control Panel. 

1. Go to Windows Start > Control Panel > Programs and Features. 
2. Right-click on the Wrapsody eCo Client (or Fasoo Wrapsody eCo) and select Repair. 
3. Proceed with the recovery as guided. 

Perform an emergency repair 
If you encounter issues while using Wrapsody eCo, you can use the emergency repair feature to restore the software. 

1. Go to Windows Start > All Programs (or All apps) > Fasoo.com > Wrapsody eCo Recovery. 
2. Proceed with the recovery as guided. 

Reinstall the client 
You can either uninstall the Wrapsody eCo client using the installation program or remove it from the Control Panel 
remove it from the Control Panel, and then proceed to reinstall it. 


